The PowerCampus and Self Service 9.3.0 upgrade has been completed. Self Service will be made available to all users later today. Please contact the IT Help Desk if you have any issues.
Posted Jun 20, 2025 - 09:35 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2025 - 10:30 EDT
Scheduled
Our Student Information System, PowerCampus, and our online registration system, Self Service, are being upgraded from version 9.2.0 to 9.3.0 and may be unavailable from Monday, 6/16/25 until Thursday, 6/19/25. CashNet, our student billing system, is also being upgraded during this time.
If you have any questions, please contact the IT Help Desk by calling 614.222.6174 or by emailing helpdesk@ccad.edu. We will notify you when the upgrade is complete and system access has been restored.
—Library & Information Technology
Posted Jun 18, 2025 - 10:25 EDT
This scheduled maintenance affected: CashNet, PowerCampus, and Self Service.