Some Self Service links not working
Incident Report for Columbus College of Art & Design
Resolved
The links for Self Service have been updated on the CCAD website and Moodle. If you have any bookmarks for Self Service that point to https://ss.ccad.edu/selfserv/Home.aspx, please update them to the correct link https://ss.ccad.edu/selfserv.

Also, if you have any links to Self Service in regular communications, please make sure to update them.

Thanks,
Library & Information Technology
Posted Oct 02, 2021 - 11:32 EDT
Investigating
You may experience issues connecting to certain Self Service links that direct you to a page that says Can't connect to the site, or 404 page not found. This is because of recent maintenance on the site, and we are working to find a solution and will update you as soon as we can.

In the meantime, use this link to connect to Self Service:
https://ss.ccad.edu/selfserv
Posted Sep 27, 2021 - 16:56 EDT
This incident affected: Self Service.