PowerCampus and Self Service update
Incident Report for Columbus College of Art & Design
Resolved
CashNet is up and running again. The Make a Payment link is back on Self Service under the Finances menu.


—Library & Information Technology
Posted Aug 08, 2022 - 11:55 EDT
Update
Logins to PowerCampus have been resolved. We are still working on bringing updated transactions into CashNet, and will update you again as soon as we can.

—Library & Information Technology
Posted Aug 04, 2022 - 10:03 EDT
Identified
We are aware of an issue preventing logins to PowerCampus. We are working on fixing the connections connections, and pushing the fix to users' computers. Self Service is operational, but CashNet is still undergoing maintenance. The Make a Payment link has been removed from Self Service, and a message has been placed on the Self Service home page informing users.

We will update you again as soon as we can. If you have any questions, please contact the IT Help Desk.

—Library & Information Technology
Posted Aug 03, 2022 - 18:04 EDT
This incident affected: CashNet and PowerCampus.