Email switchover from Microsoft Exchange to Gmail
Incident Report for Columbus College of Art & Design
Resolved
You can now log into your CCAD Gmail account by going to mail.ccad.edu or Gmail.com.
Enjoy! But reminder DON'T DELETE ANYTHING.
Posted Apr 24, 2020 - 21:43 UTC
Identified
There is a slight delay in the activation of new CCAD Gmail accounts.
Because of this you will not be able to log into your new email account. We will provide you with updates and let you know once this issue has been resolved.
Posted Apr 24, 2020 - 21:30 UTC
This incident affected: Google (Gmail).