Slow Internet speeds
Incident Report for Columbus College of Art & Design
Resolved
We have identified the cause of the network issues have applied a fix. Network speeds should be back to normal. If you are still experiencing issues connecting to the Internet, please contact the IT Help Desk at 614-222-6174 or helpdesk@ccad.edu.


—Library & Information Technology
Posted Apr 23, 2024 - 13:14 EDT
Investigating
We are aware of issues with slow download speeds connecting to the Internet on campus networks. Certain websites may take longer than normal to load. IT is engaged with our vendor to resolve this issue, and we will provide another update as soon as possible.


—Library & Information Technology
Posted Apr 23, 2024 - 10:22 EDT
This incident affected: Campus Network.